const regex = /\D/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D', 'gm')
const str = `/Date(123456789)/
Agora não considera mais esses caracteres: []^\\_
e só deixa os números: 1234 567`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);