package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SC003(.+?)(?:,|$)`)
var str = `SC001rug,SC002nw,SC003nrge`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}