const regex = /SC003(.+?)(?:,|$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SC003(.+?)(?:,|$)', '')
const str = `SC001rug,SC002nw,SC003nrge`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}