$re = '/SC003(.+?)(?:,|$)/';
$str = 'SC001rug,SC002nw,SC003nrge';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);