import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"\\w.+\"=\"(?P<device_name>.+)\"";
final String string = "\"hostname\"=\"iPhone\"\n"
+ "\"hostname\"=\"DESKTOP-8HGF56\"\n"
+ "\"hostname\"=\"Mac 0815\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}