$re = '/"\w.+"="(?P<device_name>.+)"/m';
$str = '"hostname"="iPhone"
"hostname"="DESKTOP-8HGF56"
"hostname"="Mac 0815"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);