// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"\w.+"="(?P<device_name>.+)""#).unwrap();
let string = "\"hostname\"=\"iPhone\"
\"hostname\"=\"DESKTOP-8HGF56\"
\"hostname\"=\"Mac 0815\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}