package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-zA-Z]{1,2}\d{1,2})\s{1,1}\*?(\d[a-zA-Z]{2})$`)
var str = `m20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP
CF10 1SA
CF10,1sa
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}