import re
regex = re.compile(r"^([a-zA-Z]{1,2}\d{1,2})\s{1,1}\*?(\d[a-zA-Z]{2})$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("m20 5qj\n"
"BS3 1JP\n"
"bs3 1jp\n"
"m5 8wa\n"
"m205qj\n"
"Bs31JP\n"
"CF10 1SA\n"
"CF10,1sa\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")