import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(?=.*[<>].*)\\s+([ziowauZIOWAU])\\s+(?=[^>]*<)|\\s+([ziowauZIOWAU])\\s+)";
final String string = "Litwo! Ojczyzno moja! Ty jesteś jak zdrowie. Ile cię stracił. Dziś piękność widziana więc będzie i bagnami skradał się strony obie Tadeusz przyglądał się sam wewnątrz siebie czuł wtenczas, że nam się od płaczu! On wolał z Polski trzech mocarzów albo człowiek cudzy gdy wyszedł z nieba dochodziło mniej był ochmistrzyni pokój! Fortepiano? Na niem noty i byle nie ma żądło w latach dojrzałą. Lecz młodzież lepsza, ale powiedzieć nie dostrzegł, nazbyt rychło znikła ale nigdzie nie odrodził dobrze zachowana sklepienie całe zniszczone sekwestrami rządu bezładnością opieki, wyrokami sądu w prawo psy tuż, i patrzył wzrokiem śmiałym, w tym domu dawne obyczaje chowa i niewesoły rozbierał myślą wszystkie Tadeusza cnoty i w oknie stał w tylu brzemienna imionami rycerzy, od słońca blasku Świecił się człowiek uczy ważyć, jak dziecko do sieni siadł pomiędzy nim fajt na tyle nauki lękał się, mówiąc, że w strony przeciwne wezwiemy na urząd wielkie polowanie. I włos u jednej dwórórki. Wyczha! poszli, a mój Rejencie, prawda, bez nosów opatrzonych w koryta rozlewa. Sędzia, a potem między dwie strony: Uciszcie się! woła. Marząc i uroda jej.\n";
final String subst = " $2 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}