use strict;
my $str = 'Litwo! Ojczyzno moja! Ty jesteś jak zdrowie. Ile cię stracił. Dziś piękność widziana więc będzie i bagnami skradał się strony obie Tadeusz przyglądał się sam wewnątrz siebie czuł wtenczas, że nam się od płaczu! On wolał z Polski trzech mocarzów albo człowiek cudzy gdy wyszedł z nieba dochodziło mniej był ochmistrzyni pokój! Fortepiano? Na niem noty i byle nie ma żądło w latach dojrzałą. Lecz młodzież lepsza, ale powiedzieć nie dostrzegł, nazbyt rychło znikła ale nigdzie nie odrodził dobrze zachowana sklepienie całe zniszczone sekwestrami rządu bezładnością opieki, wyrokami sądu w prawo psy tuż, i patrzył wzrokiem śmiałym, w tym domu dawne obyczaje chowa i niewesoły rozbierał myślą wszystkie Tadeusza cnoty i w oknie stał w tylu brzemienna imionami rycerzy, od słońca blasku Świecił się człowiek uczy ważyć, jak dziecko do sieni siadł pomiędzy nim fajt na tyle nauki lękał się, mówiąc, że w strony przeciwne wezwiemy na urząd wielkie polowanie. I włos u jednej dwórórki. Wyczha! poszli, a mój Rejencie, prawda, bez nosów opatrzonych w koryta rozlewa. Sędzia, a potem między dwie strony: Uciszcie się! woła. Marząc i uroda jej.
';
my $regex = qr/(?(?=.*[<>].*)\s+([ziowauZIOWAU])\s+(?=[^>]*<)|\s+([ziowauZIOWAU])\s+)/mp;
my $subst = ' $2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";