using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(.+[^ \t]+)'";
string input = @"'80 people like '80s music'?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}