$re = '/\'(.+[^ \t]+)\'/';
$str = '\'80 people like \'80s music\'?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);