package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9_-]{1,63}(?:\.[A-Za-z0-9_-]{1,63})+$`)
var str = `vuejs-complete-guide-vue-course.vue.test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}