re = /^[A-Za-z0-9_-]{1,63}(?:\.[A-Za-z0-9_-]{1,63})+$/m
str = 'vuejs-complete-guide-vue-course.vue.test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end