// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z0-9_-]{1,63}(?:\.[A-Za-z0-9_-]{1,63})+$").unwrap();
let string = "vuejs-complete-guide-vue-course.vue.test";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}