using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)-+BEGIN PRIVATE KEY-+.*?-+END PRIVATE KEY-+";
string input = @"whatever
-----BEGIN PRIVATE KEY-----
DANBgkqhkiG9w0BFQEFAASCBKkwggSlAgEA
DANBgkqhkiG9w0BFQEFAASCBKkwggSlAgEA
DANBgkqhkiG9w0BFQEFAASCBKkwggSlAgEA
s1HQDfvgtTziGzwFxggjxYvfOw==
-----END PRIVATE KEY-----
whatever";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}