re = /(?s)-+BEGIN PRIVATE KEY-+.*?-+END PRIVATE KEY-+/m
str = 'whatever
-----BEGIN PRIVATE KEY-----
DANBgkqhkiG9w0BFQEFAASCBKkwggSlAgEA
DANBgkqhkiG9w0BFQEFAASCBKkwggSlAgEA
DANBgkqhkiG9w0BFQEFAASCBKkwggSlAgEA
s1HQDfvgtTziGzwFxggjxYvfOw==
-----END PRIVATE KEY-----
whatever'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end