// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)-+BEGIN PRIVATE KEY-+.*?-+END PRIVATE KEY-+").unwrap();
let string = "whatever
-----BEGIN PRIVATE KEY-----
DANBgkqhkiG9w0BFQEFAASCBKkwggSlAgEA
DANBgkqhkiG9w0BFQEFAASCBKkwggSlAgEA
DANBgkqhkiG9w0BFQEFAASCBKkwggSlAgEA
s1HQDfvgtTziGzwFxggjxYvfOw==
-----END PRIVATE KEY-----
whatever";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}