import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\]]*)]: Successful login for (.*) \\(ID: (\\d*)\\) from ((?:\\d*:)*\\d*)(?:(?:\\w*)) in session (.*)";
final String string = "[20-Nov-2015 14:49:55 +0200]: Successful login for username (ID: 299) from 127:0:0:1 in session 70573git16bu1otp0jpugm8q14";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}