re = /\[([^\]]*)]: Successful login for (.*) \(ID: (\d*)\) from ((?:\d*:)*\d*)(?:(?:\w*)) in session (.*)/
str = '[20-Nov-2015 14:49:55 +0200]: Successful login for username (ID: 299) from 127:0:0:1 in session 70573git16bu1otp0jpugm8q14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end