const regex = /\[([^\]]*)]: Successful login for (.*) \(ID: (\d*)\) from ((?:\d*:)*\d*)(?:(?:\w*)) in session (.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^\\]]*)]: Successful login for (.*) \\(ID: (\\d*)\\) from ((?:\\d*:)*\\d*)(?:(?:\\w*)) in session (.*)', 'g')
const str = `[20-Nov-2015 14:49:55 +0200]: Successful login for username (ID: 299) from 127:0:0:1 in session 70573git16bu1otp0jpugm8q14`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}