#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\`\`\`\{r \')([A-Za-z0-9-\s]+)"
Local $sString = "```{r '2b - Possible causes for discrepancy'}"
Local $sSubst = "**\2**\n\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)