import Foundation
let pattern = #"(\`\`\`\{r \')([A-Za-z0-9-\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"```{r '2b - Possible causes for discrepancy'}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"**\2**\n\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)