package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\`\`\`\{r \')([A-Za-z0-9-\s]+)`)
var str = `\`\`\`{r '2b - Possible causes for discrepancy'}`
var substitution = "**\2**\n\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}