#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*printf)([^"\n]*"[^"\n]*")*?[^"\n]*"[^"\n]{5,}""
Local $sString = ""Match":" & @CRLF & _
"write("blueberry"); // yum" & @CRLF & _
"y = 34; write("banana")" & @CRLF & _
"z = "pineapple";" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Not match:" & @CRLF & _
"p = "seed";" & @CRLF & _
"printf("-%s-", "strawberry"); // whatever" & @CRLF & _
"x = 12; printf("lime"); write("coconut")" & @CRLF & _
"x = 12;"""" write("coconut"); printf("lime");" & @CRLF & _
"write("lime"); write("lime");" & @CRLF & _
"write("lime"); write("abc printf abc"); write("lime");" & @CRLF & _
"write("lime"); write("abc printf"); write("lime");" & @CRLF & _
"write("lime"); write("p printf"); write("lime");" & @CRLF & _
"write("lime"); write("pineapple printf"); write("lime");" & @CRLF & _
"write("lime"); write(" printf"); write("lime");" & @CRLF & _
"write("lime"); write("printf abc"); write("lime");" & @CRLF & _
"write("lime"); write("printf"); write("lime");" & @CRLF & _
"write(printf"blueberry"); // yum" & @CRLF & _
"write("blueberry"printf); // yum" & @CRLF & _
"write("blueberry"); printf // yum" & @CRLF & _
"z = "pineapple printf";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")