$re = '/^(?!.*printf)([^"\n]*"[^"\n]*")*?[^"\n]*"[^"\n]{5,}"/m';
$str = '"Match":
write("blueberry"); // yum
y = 34; write("banana")
z = "pineapple";
Not match:
p = "seed";
printf("-%s-", "strawberry"); // whatever
x = 12; printf("lime"); write("coconut")
x = 12;"""" write("coconut"); printf("lime");
write("lime"); write("lime");
write("lime"); write("abc printf abc"); write("lime");
write("lime"); write("abc printf"); write("lime");
write("lime"); write("p printf"); write("lime");
write("lime"); write("pineapple printf"); write("lime");
write("lime"); write(" printf"); write("lime");
write("lime"); write("printf abc"); write("lime");
write("lime"); write("printf"); write("lime");
write(printf"blueberry"); // yum
write("blueberry"printf); // yum
write("blueberry"); printf // yum
z = "pineapple printf";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);