import Foundation
let pattern = #"^(?!.*printf)([^"\n]*"[^"\n]*")*?[^"\n]*"[^"\n]{5,}""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"Match":
write("blueberry"); // yum
y = 34; write("banana")
z = "pineapple";
Not match:
p = "seed";
printf("-%s-", "strawberry"); // whatever
x = 12; printf("lime"); write("coconut")
x = 12;"""" write("coconut"); printf("lime");
write("lime"); write("lime");
write("lime"); write("abc printf abc"); write("lime");
write("lime"); write("abc printf"); write("lime");
write("lime"); write("p printf"); write("lime");
write("lime"); write("pineapple printf"); write("lime");
write("lime"); write(" printf"); write("lime");
write("lime"); write("printf abc"); write("lime");
write("lime"); write("printf"); write("lime");
write(printf"blueberry"); // yum
write("blueberry"printf); // yum
write("blueberry"); printf // yum
z = "pineapple printf";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)