const regex = /^(?!.*\bActivityManager\b).*\bMainActivity\b.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\bActivityManager\\b).*\\bMainActivity\\b.*', 'gm')
const str = `I/ActivityManager: Start proc 2666:com.example.app/u0000 for activity {com.example.app/com.example.app.MainActivity}
Start proc 2666:com.example.app/u0000 for activity {com.example.app/com.example.app.MainActivity}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}