import Foundation
let pattern = #"^(?!.*\bActivityManager\b).*\bMainActivity\b.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
I/ActivityManager: Start proc 2666:com.example.app/u0000 for activity {com.example.app/com.example.app.MainActivity}
Start proc 2666:com.example.app/u0000 for activity {com.example.app/com.example.app.MainActivity}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)