$re = '/^(?!.*\bActivityManager\b).*\bMainActivity\b.*/m';
$str = 'I/ActivityManager: Start proc 2666:com.example.app/u0000 for activity {com.example.app/com.example.app.MainActivity}
Start proc 2666:com.example.app/u0000 for activity {com.example.app/com.example.app.MainActivity}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);