package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^txtEsp(1[0-5]|[1-9])$`)
var str = `txtEsp-1
txtEsp0
txtEsp1
txtEsp2
txtEsp3
txtEsp4
txtEsp5
txtEsp6
txtEsp7
txtEsp8
txtEsp9
txtEsp10
txtEsp11
txtEsp12
txtEsp13
txtEsp14
txtEsp15
txtEsp16
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}