// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^txtEsp(1[0-5]|[1-9])$").unwrap();
let string = "txtEsp-1
txtEsp0
txtEsp1
txtEsp2
txtEsp3
txtEsp4
txtEsp5
txtEsp6
txtEsp7
txtEsp8
txtEsp9
txtEsp10
txtEsp11
txtEsp12
txtEsp13
txtEsp14
txtEsp15
txtEsp16
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}