const regex = /^txtEsp(1[0-5]|[1-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^txtEsp(1[0-5]|[1-9])$', 'gm')
const str = `txtEsp-1
txtEsp0
txtEsp1
txtEsp2
txtEsp3
txtEsp4
txtEsp5
txtEsp6
txtEsp7
txtEsp8
txtEsp9
txtEsp10
txtEsp11
txtEsp12
txtEsp13
txtEsp14
txtEsp15
txtEsp16
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}