import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?\\s*(?<amount>-*\\d+,\\d+)\\s*$";
final String string = " 31-12-2019 Forfait 01-01-2019 - 31-12-2019 -29,00 \n"
+ "31-12-2019Forfait 01-01-2019 - 31-12-201950,00\n"
+ "31-12-2019Mercedes-500,00\n"
+ "31-12-2019Client10 700,00\n"
+ "31-12-2019Comptoir17 50,00\n\n"
+ "// edge cases\n"
+ "31-12-2019Client 10700,00\n"
+ "31-12-2019Client 10-700,00\n"
+ "31-12-2019Client 10 700,00\n"
+ "31-12-2019Comptoir 1750,00\n"
+ "31-12-2019Comptoir 17-50,00\n"
+ "31-12-2019Comptoir 17 50,00\n\n"
+ "// versions related to [https://regex101.com/r/7TdghZ/1] ...\n\n"
+ "^\\s*(?<date>\\d{2}-\\d{2}-\\d{4})\\s*(?<text>[^\\s-]+(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?)\\s*(?<amount>-*\\d+,\\d+)\n\n"
+ "(?<date>\\d{2}-\\d{2}-\\d{4})\\s*(?<text>[^\\s-]+(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?)\\s*(?<amount>-*\\d+,\\d+)\\s*$\n\n"
+ "// final version\n"
+ "(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?\\s*(?<amount>-*\\d+,\\d+)\\s*$\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}