import re
regex = re.compile(r"(?:(?:[\s-]*\d{2}-\d{2}-\d{4})+)?\s*(?<amount>-*\d+,\d+)\s*$", flags=re.MULTILINE)
test_str = (" 31-12-2019 Forfait 01-01-2019 - 31-12-2019 -29,00 \n"
"31-12-2019Forfait 01-01-2019 - 31-12-201950,00\n"
"31-12-2019Mercedes-500,00\n"
"31-12-2019Client10 700,00\n"
"31-12-2019Comptoir17 50,00\n\n"
"// edge cases\n"
"31-12-2019Client 10700,00\n"
"31-12-2019Client 10-700,00\n"
"31-12-2019Client 10 700,00\n"
"31-12-2019Comptoir 1750,00\n"
"31-12-2019Comptoir 17-50,00\n"
"31-12-2019Comptoir 17 50,00\n\n"
"// versions related to [https://regex101.com/r/7TdghZ/1] ...\n\n"
"^\\s*(?<date>\\d{2}-\\d{2}-\\d{4})\\s*(?<text>[^\\s-]+(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?)\\s*(?<amount>-*\\d+,\\d+)\n\n"
"(?<date>\\d{2}-\\d{2}-\\d{4})\\s*(?<text>[^\\s-]+(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?)\\s*(?<amount>-*\\d+,\\d+)\\s*$\n\n"
"// final version\n"
"(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?\\s*(?<amount>-*\\d+,\\d+)\\s*$\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")