const regex = /(?:(?:[\s-]*\d{2}-\d{2}-\d{4})+)?\s*(?<amount>-*\d+,\d+)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?\\s*(?<amount>-*\\d+,\\d+)\\s*$', 'gm')
const str = ` 31-12-2019 Forfait 01-01-2019 - 31-12-2019 -29,00
31-12-2019Forfait 01-01-2019 - 31-12-201950,00
31-12-2019Mercedes-500,00
31-12-2019Client10 700,00
31-12-2019Comptoir17 50,00
// edge cases
31-12-2019Client 10700,00
31-12-2019Client 10-700,00
31-12-2019Client 10 700,00
31-12-2019Comptoir 1750,00
31-12-2019Comptoir 17-50,00
31-12-2019Comptoir 17 50,00
// versions related to [https://regex101.com/r/7TdghZ/1] ...
^\\s*(?<date>\\d{2}-\\d{2}-\\d{4})\\s*(?<text>[^\\s-]+(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?)\\s*(?<amount>-*\\d+,\\d+)
(?<date>\\d{2}-\\d{2}-\\d{4})\\s*(?<text>[^\\s-]+(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?)\\s*(?<amount>-*\\d+,\\d+)\\s*\$
// final version
(?:(?:[\\s-]*\\d{2}-\\d{2}-\\d{4})+)?\\s*(?<amount>-*\\d+,\\d+)\\s*\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}