const regex = /([\w\_]+)\:\>\"((?:[^"\\]|\\.)*)\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w\\_]+)\\:\\>\\"((?:[^"\\\\]|\\\\.)*)\\"', 'gm')
const str = `2020-02-20 20:22:02.202020 test:>"value" test1:>"value1" test2:>"this is a \\"test\\"" test3:>"this is \\"a test\\" ok" test4:>"this is \\"another\\" test ok?"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}