use strict;
my $str = '2020-02-20 20:22:02.202020 test:>"value" test1:>"value1" test2:>"this is a \\"test\\"" test3:>"this is \\"a test\\" ok" test4:>"this is \\"another\\" test ok?"
';
my $regex = qr/([\w\_]+)\:\>\"((?:[^"\\]|\\.)*)\"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}