$re = '/([\w\_]+)\:\>\"((?:[^"\\\\]|\\\\.)*)\"/m';
$str = '2020-02-20 20:22:02.202020 test:>"value" test1:>"value1" test2:>"this is a \\"test\\"" test3:>"this is \\"a test\\" ok" test4:>"this is \\"another\\" test ok?"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);