using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[+]6)?0(([0-9]{2}((\s[0-9]{3,4}\s[0-9]{4})|(-[0-9]{3,4}\s[0-9]{4})|(-[0-9]{7,8})))|([0-9]{9,10}))$";
string input = @"01234567890
+601234567890
012-34567890
+6012-34567890
012-3456 7890
+6012-3456 7890
012 3456 7890
+6012 3456 7890
#invalid:
0122 3456 7890
12 3456 7890
+60122 3456 7890
012345678900
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}