re = /^(?:[+]6)?0(([0-9]{2}((\s[0-9]{3,4}\s[0-9]{4})|(-[0-9]{3,4}\s[0-9]{4})|(-[0-9]{7,8})))|([0-9]{9,10}))$/m
str = '01234567890
+601234567890
012-34567890
+6012-34567890
012-3456 7890
+6012-3456 7890
012 3456 7890
+6012 3456 7890
#invalid:
0122 3456 7890
12 3456 7890
+60122 3456 7890
012345678900
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end