package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:.){2,})`)
var str = `word boundaries are odd
\n
\n\n
\n\n\n
\n \n
\n \n \n
\n \n
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}