$re = '/((?:.){2,})/';
$str = 'word boundaries are odd
\\n
\\n\\n
\\n\\n\\n
\\n \\n
\\n \\n \\n
\\n \\n
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);