#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:\w+\W+){0,18}(\d{1,2}(\.|\/|-)\d{1,2}(\.|\/|-)\d{2,4})"
Local $sString = "" & @CRLF & _
""" & @CRLF & _
"" & @CRLF & _
"BIRADS: 0, Incomplete - need prior mammograms for comparison" & @CRLF & _
"" & @CRLF & _
"A breast health history was obtained and a risk assessment" & @CRLF & _
"analysis of the patient's lifetime risk of breast malignancy was" & @CRLF & _
"completed. These models indicate a lifetime risk of breast" & @CRLF & _
"malignancy as follows:" & @CRLF & _
"" & @CRLF & _
"Tyrer-Cuzick 10-year: 8.6 %..........[average woman <5%]" & @CRLF & _
"Tyrer-Cuzick Lifetime: 21.4 %..........[average woman" & @CRLF & _
"<12%]" & @CRLF & _
"Myriad Table: 2.6 %..........[average woman" & @CRLF & _
"<5%]" & @CRLF & _
"GAIL 5-year: 2.9 %..........[average" & @CRLF & _
"woman <1.67%]" & @CRLF & _
"NCI Lifetime: 15.1 %..........[average" & @CRLF & _
"woman <10%]" & @CRLF & _
" " & @CRLF & _
"Addendum: " & @CRLF & _
"" & @CRLF & _
"Date Addendum Dictated: 7/19/2019" & @CRLF & _
"" & @CRLF & _
"BIRADS: 2, benign findings" & @CRLF & _
"" & @CRLF & _
"Recommend: " & @CRLF & _
"1: Routine screening mammogram in 1 year" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")