use strict;
my $str = '
"
BIRADS: 0, Incomplete - need prior mammograms for comparison
A breast health history was obtained and a risk assessment
analysis of the patient\'s lifetime risk of breast malignancy was
completed. These models indicate a lifetime risk of breast
malignancy as follows:
Tyrer-Cuzick 10-year: 8.6 %..........[average woman <5%]
Tyrer-Cuzick Lifetime: 21.4 %..........[average woman
<12%]
Myriad Table: 2.6 %..........[average woman
<5%]
GAIL 5-year: 2.9 %..........[average
woman <1.67%]
NCI Lifetime: 15.1 %..........[average
woman <10%]
Addendum:
Date Addendum Dictated: 7/19/2019
BIRADS: 2, benign findings
Recommend:
1: Routine screening mammogram in 1 year
';
my $regex = qr/(?:\w+\W+){0,18}(\d{1,2}(\.|\/|-)\d{1,2}(\.|\/|-)\d{2,4})/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}