# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\w+\W+){0,18}(\d{1,2}(\.|\/|-)\d{1,2}(\.|\/|-)\d{2,4})"
test_str = ("\n"
"\"\n\n"
"BIRADS: 0, Incomplete - need prior mammograms for comparison\n\n"
"A breast health history was obtained and a risk assessment\n"
"analysis of the patient's lifetime risk of breast malignancy was\n"
"completed. These models indicate a lifetime risk of breast\n"
"malignancy as follows:\n\n"
"Tyrer-Cuzick 10-year: 8.6 %..........[average woman <5%]\n"
"Tyrer-Cuzick Lifetime: 21.4 %..........[average woman\n"
"<12%]\n"
"Myriad Table: 2.6 %..........[average woman\n"
"<5%]\n"
"GAIL 5-year: 2.9 %..........[average\n"
"woman <1.67%]\n"
"NCI Lifetime: 15.1 %..........[average\n"
"woman <10%]\n"
" \n"
"Addendum: \n\n"
"Date Addendum Dictated: 7/19/2019\n\n"
"BIRADS: 2, benign findings\n\n"
"Recommend: \n"
"1: Routine screening mammogram in 1 year\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.