package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*([^!.?]*?NSF[^!.?]*?[?])`)
var str = `This is a string. Is this a question? This isn't a question about NSF. Is this one about NSF? This one is a question about NSF but is it longer?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}