$re = '/\s*([^!.?]*?NSF[^!.?]*?[?])/';
$str = 'This is a string. Is this a question? This isn\'t a question about NSF. Is this one about NSF? This one is a question about NSF but is it longer?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);