$re = '/\b[a-zA-Z]{2}\w+[a-zA-Z]{3}\b/m';
$str = 'Please find the ref AB45676785567XYZ. which is used to identify reference number';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);